Author Topic: Set up IIS and PHP for CalemEAM  (Read 18589 times)

LISpeedyG

  • Newbie
  • *
  • Posts: 10
Set up IIS and PHP for CalemEAM
« on: October 22, 2007, 11:09:26 pm »
OK This has been a very adruous task..  More frustration than I bargained for..

Anyway, I managed to get PHP 5.2.2 on IIS responding somewhat well. Although, I am getting an intermittant crash (of sorts) from a helper task on IIS6.  Also, I have installed MYSql Server version: 5.0.45.

I also managed to get to your Database installation step 2 in loading the initial data and now it failed since apparently PEAR.php was unavailable.  See details below..  It appears that there was a bug in the msi package and PEAR does not install correctly.  And, this is the best version there is of PHP.  I have tried several other version all failed under IIS.  

Anyway, I have struggled to find the correct solution but now I am at an impass.  I cannot figure out.  If you folks can give me a hand I would appreciate it.  I am at the end of my rope here..

Thanks,
Gus

****************** ERROR ********************
C:\Inetpub\wwwroot\CalemEAM\bin\database>echo off
load init data
PHP Warning:  Module 'mysql' already loaded in Unknown on line 0
PHP Warning:  Module 'PDO' already loaded in Unknown on line 0
PHP Warning:  Module 'pdo_mysql' already loaded in Unknown on line 0
PHP Warning:  Module 'mbstring' already loaded in Unknown on line 0
PHP Warning:  Module 'mysqli' already loaded in Unknown on line 0
PHP Notice:  Only variable references should be returned by reference in C:\Inetpub\wwwroot\CalemEA
\server\include\log4php\LoggerAppender.php on line 73
PHP Notice:  Only variable references should be returned by reference in C:\Inetpub\wwwroot\CalemEA
\server\include\log4php\LoggerPropertyConfigurator.php on line 565
October 23, 2007, 12:49:16 am - Loading init data...<br>
PHP Warning:  Cache_Lite::include_once(PEAR.php): failed to open stream: No such file or directory
n C:\Inetpub\wwwroot\CalemEAM\server\include\Cache_Lite\Lite.php on line 479
PHP Warning:  Cache_Lite::include_once(): Failed opening 'PEAR.php' for inclusion (include_path='C:
Inetpub\wwwroot\CalemEAM/server/include;.;c:\php;c:\php\includes;C:\Inetpub\wwwroot\JPGraph;C:\phpm
iler-1.73\phpmailer') in C:\Inetpub\wwwroot\CalemEAM\server\include\Cache_Lite\Lite.php on line 479
PHP Fatal error:  Class 'PEAR' not found in C:\Inetpub\wwwroot\CalemEAM\server\include\Cache_Lite\L
te.php on line 480

C:\Inetpub\wwwroot\CalemEAM\bin\database>
*********************** ERROR END ***************************

LISpeedyG

  • Newbie
  • *
  • Posts: 10
Set up IIS and PHP for CalemEAM
« Reply #1 on: October 23, 2007, 08:07:15 am »
Well I managed to get the data loaded but I did get a number of warnings both during the PEAR installation as well as during the data load.  However, the data seems to be in place now..  What a frustrating night!!

Anyway, I am now able to get to the login screen but I am not able to go beyond..  I now get a "cannot find server or DNS" ...  I am running off other than port 80.  SO I suspect that it is a port issue.  Can you tell me if there are any settings required to be tweaked in your application for this..  I am now able to successfully use PHPMyAdmin as well as other PHP apps.  So, That is why I suspect there might be some issue within your app.  Also, another suspicion is that I do nto see any graphics on the login page..

Any help would be appreciated..

Thanks,
Gus

LISpeedyG

  • Newbie
  • *
  • Posts: 10
Set up IIS and PHP for CalemEAM
« Reply #2 on: October 23, 2007, 11:08:48 am »
OK I figured it out..

Apparently it was an HTTPS issue.  Since my server was not set up for the security level it was not enabling me to get to the next stage after the login attempt.

The way I fixed the problem:
I edited ..\Server\Conf\Calem.PHP the following line:
'calem_host'=>array('http'=>'http://', 'https'=>'https://')
TO
'calem_host'=>array('http'=>'http://', 'https'=>'http://')

As soon as the fix was made the IIS6 server now responds to the application..

I will update on my application use next..

Gus

woodelf

  • Newbie
  • *
  • Posts: 3
Set up IIS and PHP for CalemEAM
« Reply #3 on: November 01, 2007, 10:35:40 pm »
Hi I faced exactly the same issues with setting up a test installation on XP pro running IIS 5.1, PHP 5.2.4 & mySQL 5.0.45

I now get the login page displaying correctly - but cannot log-in with "admin" & "admin_password" (Login failed. Please check your user name/password and try again.)

FYI - going to login screen gives these warnings:

Notice: Only variable references should be returned by reference in C:\Inetpub\wwwroot\CalemEAM\server\include\log4php\LoggerAppender.php on line 73

Notice: Only variable references should be returned by reference in C:\Inetpub\wwwroot\CalemEAM\server\include\log4php\LoggerPropertyConfigurator.php on line 565

Notice: Undefined index: aid in C:\Inetpub\wwwroot\CalemEAM\index.php on line 44

Notice: Undefined variable: sesReload in C:\Inetpub\wwwroot\CalemEAM\index.php on line 101

Notice: Undefined index: aid in C:\Inetpub\wwwroot\CalemEAM\index.php on line 124


And actually on the login box:
Notice: Undefined variable: loginErrorText in C:\Inetpub\wwwroot\CalemEAM\client\launchpad\CalemLoginLite.php on line 210

Also note my system has to use UTF-8

Any help greatly appreciated...
egards, Woodelf

woodelf

  • Newbie
  • *
  • Posts: 3
Set up IIS and PHP for CalemEAM
« Reply #4 on: November 13, 2007, 03:26:49 am »
Any one have any ideas on this - this unresolved error in the login screen... "Notice: Undefined variable: loginErrorText in C:\Inetpub\wwwroot\CalemEAM\client\launchpad\CalemLoginLite.php on line 210"

So far I've been unable to resovle it !

Thanks,
egards, Woodelf

calemadmin

  • Administrator
  • Calem Hero
  • *****
  • Posts: 300
    • http://www.calemeam.com
Set up IIS and PHP for CalemEAM
« Reply #5 on: November 13, 2007, 08:05:18 am »
This error is a notice and does not affect your use of the product. If you really need to get rid of it and other notices make a change in php.ini. Take a quick look at the document link:
http://www.php.net/manual/en/ref.errorfunc.php
Calem Community Forum Admin

woodelf

  • Newbie
  • *
  • Posts: 3
Set up IIS and PHP for CalemEAM
« Reply #6 on: November 13, 2007, 09:10:28 pm »
Hi, problem is I can not login.

Using admin/admin_password gives "Login failed. Please check your user name/password and try again."

... is this a problem with utf-8 ?

Any help would be much appreciated, thanks.
egards, Woodelf

calemadmin

  • Administrator
  • Calem Hero
  • *****
  • Posts: 300
    • http://www.calemeam.com
Set up IIS and PHP for CalemEAM
« Reply #7 on: November 14, 2007, 08:20:52 am »
You may paste logs from php error log and calem logs we can take a look.
- php error logs
- calem logs (under CalemEAM/logs/calem.log)

utf-8 works fine with CalemEAM.
Calem Community Forum Admin