Author Topic: STILL cannot login...  (Read 7287 times)

jeremyd

  • Newbie
  • *
  • Posts: 2
STILL cannot login...
« on: April 22, 2008, 09:49:49 pm »
I know this is very tiresome, but after reading through every post on the forum related to this problem, I still cannot login.

I am getting the same set of errors reported by others; but none of the    solutions have worked.

Any help you can provide would be much appreciated.  It looks like a really cool product....
=============================

Details:
WinXP Home, SP2
Apache 2.0.52, MySQL 5.0.51a, PHP 5.2.5 (installed separately)

Apache2/conf/httpd.conf does not have any extensions configured

PHP/php.ini has the following extensions configured:
   [PHP_PDO]
   extension=php_pdo.dll
   [PHP_PDO_MYSQL]
   extension=php_pdo_mysql.dll

php.ini also has PEAR in the path:
   include_path = ".;c:\Program Files\PHP\PEAR"

There are no other php.ini files on my system, in c:/windows or elsewhere.

I've restarted Apache (several times) after changing the php.ini and httpd.conf files.  It starts up with no errors.

PEAR modules installed
Archive_Tar; Console_Getopt; HTTP_Request; Net_Socket; Net_URL; PEAR; SOAP; Structures_Graph; XML_Parser

I've verified there is a database user 'calemeam', password 'calemeam'.  I can login to MySQL as this user, using MySQL Query Browser.

I've verified there is a record in the user table 'admin', password md5('admin_password').  I updated it manually just in case:
   update users set password=md5('admin_password') where username = 'admin';

I have followed all the steps in the setup Guide, except #5 (chart setup).  

I've re-run step #7 (client deploy).  When I try it again, it says "logging is already configured"

Below are the errors I'm getting:
(note: calem.dunn.org resolves to localhost.  I have it setup in my local 'hosts' file since I'm running a number of sites locally)

Apache error log:
==================================
[Tue Apr 22 23:26:16 2008] [error] [client 127.0.0.1] PHP Notice:  Only variable references should be returned by reference in C:\\web\\calem\\CalemEAM\\server\\include\\log4php\\LoggerAppender.php on line 73, referer: http://calem.dunn.org/CalemEAM/index.php
[Tue Apr 22 23:26:16 2008] [error] [client 127.0.0.1] PHP Notice:  Only variable references should be returned by reference in C:\\web\\calem\\CalemEAM\\server\\include\\log4php\\LoggerPropertyConfigurator.php on line 565, referer: http://calem.dunn.org/CalemEAM/index.php
[Tue Apr 22 23:26:16 2008] [error] [client 127.0.0.1] PHP Notice:  Undefined index:  aid in C:\\web\\calem\\CalemEAM\\index.php on line 44, referer: http://calem.dunn.org/CalemEAM/index.php
[Tue Apr 22 23:26:17 2008] [error] [client 127.0.0.1] PHP Notice:  Undefined index:  CALEM_LANG in C:\\web\\calem\\CalemEAM\\client\\launchpad\\CalemLoginLite.php on line 32, referer: http://calem.dunn.org/CalemEAM/index.php
==================================

php error log
==================================
2008-04-22 23:26:16,972 DEBUG main - sid=; aid=, Post data: username=admin&password=admin_password&lang=&loadmode=gzip&theme=calem&debug=&calemAction=LoginAction
2008-04-22 23:26:17,972 INFO  MysqlHandler - calem db connection: user=calemeam, password=***, , connection=mysql:host=localhost;dbname=calemeam, persistent connection=Array
2008-04-22 23:26:17,972 ERROR main - Exception in processing login. Error msg=#0 C:\web\calem\CalemEAM\server\include\core\database\CalemPdo.php(53): PDO->__construct('mysql:host=loca...', 'calemeam', 'calemeam', Array)
#1 C:\web\calem\CalemEAM\server\include\core\database\mysql\MysqlHandler.php(148): CalemPdo->__construct('mysql:host=loca...', 'calemeam', 'calemeam', Array)
#2 C:\web\calem\CalemEAM\server\include\core\database\CalemDbo.php(79): MysqlHandler->getCalemConnection()
#3 C:\web\calem\CalemEAM\server\include\core\CalemFactory.php(146): CalemDbo->__construct()
#4 C:\web\calem\CalemEAM\server\include\core\CalemFactory.php(98): CalemFactory::createInstance(Array)
#5 C:\web\calem\CalemEAM\server\modules\admin\CalemUserDbo.php(48): CalemFactory::getDbo('users')
#6 C:\web\calem\CalemEAM\server\modules\admin\CalemSecurityBo.php(62): CalemUserDbo::findByUsername('admin')
#7 C:\web\calem\CalemEAM\server\modules\admin\soap\CalemLoginSo.php(67): CalemSecurityBo->verifyLogin('admin', 'admin_password')
#8 C:\web\calem\CalemEAM\index.php(57): CalemLoginSo::doLogin('admin', 'admin_password')
#9 {main}
===================================

jeremyd

  • Newbie
  • *
  • Posts: 2
re: STILL cannot login
« Reply #1 on: April 27, 2008, 02:36:29 pm »
The problem was solved by changing the ORDER of extension-loads in php.ini.

I put PHP_PDO *before* PHP_PDO_MYSQL and PHP_MYSQL.  That did it.

Here's a snipped from php.ini:

==================
[PHP_PDO]
extension=php_pdo.dll
[PHP_PDO_MYSQL]
extension=php_pdo_mysql.dll
[PHP_MYSQL]
extension=php_mysql.dll
==================

See this bug-posting for more information:
http://bugs.php.net/bug.php?id=35345