Author Topic: Cannot get past "Loading" Graphic ...  (Read 5089 times)

resn8r

  • Newbie
  • *
  • Posts: 3
Cannot get past "Loading" Graphic ...
« on: June 11, 2013, 07:46:38 am »
I have installed Calem EAM per the instructions, gotten the database created, etc., but after entering admin and admin_password, the system just displays "loading"  I have tried most solutions in the forums, but to no avail.  I suspect that I am missing some small configuration, but need some help.  I'm on a Windows 8 system with XAMPP (latest version), but the same issue is happening on a Windows 7 machine as well - exact same issue.

(And I tried to attach logs, but am limited by the 4000 char limit.)  The logs show that the program tends to hang on the "adding files for download" part of logging in.

Regards,
Miles

resn8r

  • Newbie
  • *
  • Posts: 3
Re: Cannot get past "Loading" Graphic ...
« Reply #1 on: June 14, 2013, 07:03:26 am »
Errors popping up on login page:

Notice: Only variable references should be returned by reference in C:\xampp\htdocs\CalemEAM\server\include\log4php\LoggerPropertyConfigurator.php on line 567

Notice: Undefined variable: sesReload in C:\xampp\htdocs\CalemEAM\index.php on line 111

Notice: Undefined index: aid in C:\xampp\htdocs\CalemEAM\index.php on line 133

Notice: Undefined index: CALEM_LANG in C:\xampp\htdocs\CalemEAM\client\launchpad\CalemLoginLite.php on line 33

Notice: Undefined variable: loginErrorText in C:\xampp\htdocs\CalemEAM\client\launchpad\CalemLoginLite.php on line 211

I'm assuming that there is something path-wise or other related to this, but am wasting time tracing all the errors.  Anyone out there anymore that reads the forums?

calemadmin

  • Administrator
  • Calem Hero
  • *****
  • Posts: 300
    • http://www.calemeam.com
Re: Cannot get past "Loading" Graphic ...
« Reply #2 on: October 05, 2013, 04:35:28 pm »
Error reporting in php.ini might have a default value to show all minor notices, which interferes with the web page rendering.
error_reporting = E_ALL

If you are using PHP 5.3.x with Calem Enterprise ionCube release, the error reporting needs to be:
error_reporting = E_ALL & ~E_NOTICE & ~E_STRICT & ~E_DEPRECATED

The configuration needs to be set to the following in your php.ini for PHP 5.2.x:
error_reporting = E_ALL & ~E_NOTICE & ~E_STRICT
Calem Community Forum Admin

calemadmin

  • Administrator
  • Calem Hero
  • *****
  • Posts: 300
    • http://www.calemeam.com
Re: Cannot get past "Loading" Graphic ...
« Reply #3 on: October 06, 2013, 10:24:42 am »
A blank screen persists after fixing the above issue. CalemEAM/server/cache/data is empty. The cache file is initialized by the installation process. So, make sure you run the web installation one more time to have the cache data created.

There are also issues running web installation and product at some hosting environment such as Hosting Gator. Do the following to address the issue:
1. Comment out the cache configuration below in CalemEAM/installation/index.php at line 34:
//header('Cache-Control', 'no-cache');

2. Comment out the same line in CalemEAM/index.php at line 44:
//header('Cache-Control', 'no-cache');

Calem Community Forum Admin

calemadmin

  • Administrator
  • Calem Hero
  • *****
  • Posts: 300
    • http://www.calemeam.com
Re: Cannot get past "Loading" Graphic ...
« Reply #4 on: October 06, 2013, 04:29:09 pm »
There are also issues with running the application in hosted environment. A release R2.1a has been made available to address this issue.
https://sourceforge.net/projects/calemeam/files/CalemEAM%20Community%20Edition/Calem%20Community%20Edition%20R2.1a/
Calem Community Forum Admin