Author Topic: Installing on a shared server with CGI based PHP  (Read 4719 times)

xllamas

  • Newbie
  • *
  • Posts: 1
Installing on a shared server with CGI based PHP
« on: October 20, 2011, 09:11:00 am »
Hi All:

Here's what I did to get CalemEAM to work on a shared server with PHP working in CGI mode:

I first tried to install directly on the server but it didn't work, it hung on the first installation page. I then installed it on my local Ubuntu machine with PHP as an apache module where it worked fine (I don't use LAMP but I guessed that having apache, php and mysql would be Ok). I then tared and gziped everything and moved it to the shared server. I dumped the database and recreated it on the shared server, and I also edited server/conf/calem.install.php and changed to the appropriate values for my server.  But it didn't work either, It hung at the login page.

I traced the program outputing messages to the log file and I found that the problem is with the:

header('Cache-Control', 'no-cache');

instruction. For some reason PHP complains that it is receiving malformed headers, so I commented out this instruction in the following files:

CalemSoapService.php
index.php
client/launchpad/CalemIncludeJsPkg.php

And voila! It works.

Afterwards I found that the header instruction is also in the installation script, so probably commenting it out would make the installation work directly on the server with CGI PHP:

installation/index.php

I have also translated CalemEAM to Spanish. If anyone is interested I can gladly provide the files.

Regards,
Xavier.

jenaknight

  • Newbie
  • *
  • Posts: 2
Re: Installing on a shared server with CGI based PHP
« Reply #1 on: March 11, 2013, 02:00:26 pm »
Yes please, i would like to have the files, and any instruction in how to set them up.

jenaknight

  • Newbie
  • *
  • Posts: 2
Re: Installing on a shared server with CGI based PHP
« Reply #2 on: March 04, 2014, 03:00:18 pm »
Me too if possible