Author Topic: thought I did everything right  (Read 4769 times)

andreas

  • Newbie
  • *
  • Posts: 4
thought I did everything right
« on: June 12, 2007, 09:45:42 am »
the only thing I get is this

Parse error: parse error, unexpected '{' in C:\xampp\htdocs\CalemEAM\index.php on line 55

can anybody help?

calemadmin

  • Administrator
  • Calem Hero
  • *****
  • Posts: 300
    • http://www.calemeam.com
thought I did everything right
« Reply #1 on: June 12, 2007, 11:28:35 am »
A couple of logs to check:
- php error logs
- calem logs (under CalemEAM/logs/calem.log)

(in my xampplite installation on windows, php error log is:
C:\xampplite\apache\logs\phperror.log)
Calem Community Forum Admin

andreas

  • Newbie
  • *
  • Posts: 4
thought I did everything right
« Reply #2 on: June 13, 2007, 06:00:28 am »
did that, but there are no log files in C:\xampp\htdocs\CalemEAM\logs
and the error log C:\xampp\apache\logs is like this:

Character set '#48' is not a compiled character set and is not specified in the 'c:\mysql\share\charsets\Index' file
File 'c:\mysql\share\charsets\?.conf' not found (Errcode: 2)
Character set '#48' is not a compiled character set and is not specified in the 'c:\mysql\share\charsets\Index' file
[Tue Jun 12 11:27:47 2007] [notice] Apache/2.2.4 (Win32) DAV/2 mod_ssl/2.2.4 OpenSSL/0.9.8e mod_autoindex_color PHP/4.4.5 mod_jk/1.2.20 configured -- resuming normal operations
[Tue Jun 12 11:27:47 2007] [notice] Server built: Mar  5 2007 11:23:00
[Tue Jun 12 11:27:47 2007] [notice] Parent: Created child process 1896
[Tue Jun 12 11:27:48 2007] [notice] Child 1896: Child process is running
[Tue Jun 12 11:27:48 2007] [notice] Child 1896: Acquired the start mutex.
[Tue Jun 12 11:27:48 2007] [notice] Child 1896: Starting 250 worker threads.
[Tue Jun 12 11:27:48 2007] [notice] Child 1896: Starting thread to listen on port 80.
[Tue Jun 12 11:27:48 2007] [notice] Child 1896: Starting thread to listen on port 443.
File 'c:\mysql\share\charsets\?.conf' not found (Errcode: 2)
Character set '#48' is not a compiled character set and is not specified in the 'c:\mysql\share\charsets\Index' file
File 'c:\mysql\share\charsets\?.conf' not found (Errcode: 2)
Character set '#48' is not a compiled character set and is not specified in the 'c:\mysql\share\charsets\Index' file

calemadmin

  • Administrator
  • Calem Hero
  • *****
  • Posts: 300
    • http://www.calemeam.com
thought I did everything right
« Reply #3 on: June 13, 2007, 10:21:00 am »
You may want to fix the character set error msg below first. The encoding used by CalemEAM is: utf8_general_ci

Did the parse error below show when you use your browser to use CalemEAM? If so, which log did you see the parse error?
Calem Community Forum Admin

andreas

  • Newbie
  • *
  • Posts: 4
thought I did everything right
« Reply #4 on: June 22, 2007, 10:43:38 am »
and how do I fix the character set error?

calemadmin

  • Administrator
  • Calem Hero
  • *****
  • Posts: 300
    • http://www.calemeam.com
thought I did everything right
« Reply #5 on: June 22, 2007, 12:33:36 pm »
It's not clear how to fix the character set error. Another look at the error msg , it seemed you might have another sql server installed under c:\mysql

Since you're using xampp you may need to make sure that the sql server coming with xampp is running. You can review services from Windows to remove all mySQL services and then use xampp to verify that no sql server is running. Next use xampp to start apache/mysql.
Calem Community Forum Admin

andreas

  • Newbie
  • *
  • Posts: 4
thought I did everything right
« Reply #6 on: June 22, 2007, 12:59:52 pm »
I can assure there is no other SQL server running on this machine

calemadmin

  • Administrator
  • Calem Hero
  • *****
  • Posts: 300
    • http://www.calemeam.com
thought I did everything right
« Reply #7 on: June 22, 2007, 02:23:55 pm »
Okay, you may check out mySQL conf file (it's C:\xampplite\mysql\bin\my in my xampplite install) to see if there's any reference to c:\mysql\share\charsets
Calem Community Forum Admin