Author Topic: After finished install,login failed.  (Read 27521 times)

fortune

  • Newbie
  • *
  • Posts: 2
After finished install,login failed.
« on: July 13, 2007, 02:15:00 am »
I installed CalemEAM. And all my install step  went perfect. When I try to login to CalemEAM using admin/admin,
I get those error:



1. after input admin/admin:
 
Get following error message:

Warning: require_once(SOAP/Base.php) [function.require-once]: failed to open stream: No such file or directory in D:\wamp\www\CalemEAM\server\include\core\CalemSoapRequest.php on line 31

Fatal error: require_once() [function.require]: Failed opening required 'SOAP/Base.php' (include_path='.;D:\wamp\php\pear') in D:\wamp\www\CalemEAM\server\include\core\CalemSoapRequest.php on line 31



2. And I went to http://pear.php.net to down SOAP-0.11.0.tgz package,
  after download this , unzip and rename it as SOAP ,put it to  WAMP/PHP/PEAR/

re-login,get following error message:

Warning: require_once(XML/Serializer.php) [function.require-once]: failed to open stream: No such file or directory in D:\wamp\www\CalemEAM\server\include\core\CalemSoapRequest.php on line 32

Fatal error: require_once() [function.require]: Failed opening required 'XML/Serializer.php' (include_path='.;D:\wamp\php\pear') in D:\wamp\www\CalemEAM\server\include\core\CalemSoapRequest.php on line 32



3. And I went to http://pear.php.net to down XML_Serializer-0.18.0.tgz package,
  after download this , unzip and rename it as XML ,put it to  WAMP/PHP/PEAR/


re-login,get following error message:



Warning: require_once(XML/Util.php) [function.require-once]: failed to open stream: No such file or directory in D:\wamp\php\PEAR\XML\Serializer.php on line 35

Fatal error: require_once() [function.require]: Failed opening required 'XML/Util.php' (include_path='.;D:\wamp\php\pear') in D:\wamp\php\PEAR\XML\Serializer.php on line 35



4. So,  I went to http://pear.php.net to down XML_Util-1.1.4.tgz package,
  after download this , unzip it and copy all of file to  WAMP/PHP/PEAR/XML


re-login,get following error message but mention that ERROR username or password.

5. I login mysql and use calemeam database,then update admin user password as 'admin'
and re-login.but still mention me error username or password.


Why??

How can I do??

fortune

  • Newbie
  • *
  • Posts: 2
After finished install,login failed.
« Reply #1 on: July 13, 2007, 03:03:34 am »
I have solved this problem.
It is password error.after I change admin's password ,I can login it.

Following is step by step :

mysql> show databases;
+--------------------+
| Database           |
+--------------------+
| information_schema |
| calemeam           |
| mysql              |
| phpmyadmin         |
| test               |
+--------------------+
5 rows in set (0.14 sec)

mysql> use calemeam
Database changed
mysql> show tables;
..............

mysql> select * from users;

................

mysql> update users set password=md5('admin') where username='admin';
Query OK, 1 row affected (0.13 sec)
Rows matched: 1  Changed: 1  Warnings: 0

Mindaugas

  • Newbie
  • *
  • Posts: 1
cannot logi too
« Reply #2 on: August 08, 2007, 07:36:58 am »
Instalation went good, but I cannot login. I use ubuntu-server and I installed all SOAP and XML through apt-get. When I try to login I simply get:
"Login failed. Please check your user name/password and try again."

my log file shows:

2007-08-08 19:31:05,697 DEBUG main - sid=; Post data=username=admin&password=admin&calemAction=LoginAction
2007-08-08 19:31:05,697 INFO  MysqlHandler - calem db connection: user=calemeam, password=***, , connection=mysql:host=localh
2007-08-08 19:31:05,697 DEBUG CalemDbo - fetchBySqlParam: select * from users where username=?, param='admin'
2007-08-08 19:31:05,697 DEBUG CalemPDOStatement - Query time:0.001, the query=select * from users where username=?, params=ar
  1 => 'admin',
)
2007-08-08 19:31:06,697 INFO  main - Received request to launch: client/launchpad/CalemLoginLite.php

calemadmin

  • Administrator
  • Calem Hero
  • *****
  • Posts: 300
    • http://www.calemeam.com
After finished install,login failed.
« Reply #3 on: August 08, 2007, 12:40:40 pm »
Default login is:
admin/admin_password

Note: password for admin is 'admin_password'.
Calem Community Forum Admin

Seba

  • Newbie
  • *
  • Posts: 12
After finished install,login failed.
« Reply #4 on: September 11, 2007, 01:02:27 pm »
I've installed the system on Linux and i'm trying to log with 'admin' and 'admin_password' but i can't.

Any help?

calemadmin

  • Administrator
  • Calem Hero
  • *****
  • Posts: 300
    • http://www.calemeam.com
After finished install,login failed.
« Reply #5 on: September 11, 2007, 09:03:26 pm »
Take a look at logs. It might tell what were wrong.
- php error logs
- calem logs (under CalemEAM/logs/calem.log)
Calem Community Forum Admin

Seba

  • Newbie
  • *
  • Posts: 12
After finished install,login failed.
« Reply #6 on: September 12, 2007, 09:12:44 am »
I have no errors logs in de php logs.

Then, there's no file under CalemEAM/logs/ (the directory is empty).

I did a "updatedb && locate calem.log" with no result.

thanks.

calemadmin

  • Administrator
  • Calem Hero
  • *****
  • Posts: 300
    • http://www.calemeam.com
After finished install,login failed.
« Reply #7 on: September 12, 2007, 09:55:08 am »
Check out CalemEAM/etc/log4php.properties, does this file exist?
It's generated by CalemEAM/bin/setup.sh
Calem Community Forum Admin

Seba

  • Newbie
  • *
  • Posts: 12
After finished install,login failed.
« Reply #8 on: September 12, 2007, 10:07:57 am »
CalemEAM/etc/log4php.properties EXISTS

calemadmin

  • Administrator
  • Calem Hero
  • *****
  • Posts: 300
    • http://www.calemeam.com
After finished install,login failed.
« Reply #9 on: September 12, 2007, 10:35:31 am »
Ok, let's check the access log and Apache error log, see if there's any clue.
By the way, what's the linux os? When you login with admin/admin_password, what's showing on the browser? Any error msg?
Calem Community Forum Admin

Seba

  • Newbie
  • *
  • Posts: 12
After finished install,login failed.
« Reply #10 on: September 12, 2007, 12:06:30 pm »
access_log:

10.0.8.9 - - [12/Sep/2007:14:39:35 -0300] "GET /CalemEAM HTTP/1.1" 301 402
10.0.8.9 - - [12/Sep/2007:14:39:35 -0300] "GET /CalemEAM/ HTTP/1.1" 200 7178
10.0.8.9 - - [12/Sep/2007:14:39:35 -0300] "GET /CalemEAM/client/themes/favicon.ico HTTP/1.1" 200 1150
10.0.8.9 - - [12/Sep/2007:14:39:35 -0300] "GET /CalemEAM/client/themes/image/hiRes/dwtimgs.css HTTP/1.1" 200 35247
10.0.8.9 - - [12/Sep/2007:14:39:35 -0300] "GET /CalemEAM/client/themes/login.css HTTP/1.1" 200 1749
10.0.8.9 - - [12/Sep/2007:14:39:36 -0300] "GET /CalemEAM/client/themes/image/hiRes/dwt/Critical_32.gif HTTP/1.1" 200 1458
10.0.8.9 - - [12/Sep/2007:14:39:36 -0300] "GET /CalemEAM/client/themes/calemeam.png HTTP/1.1" 200 2905
10.0.8.9 - - [12/Sep/2007:14:39:48 -0300] "POST /CalemEAM/index.php HTTP/1.1" 200 7263

error_log:

[Wed Sep 12 11:55:54 2007] [notice] caught SIGTERM, shutting down
[Wed Sep 12 11:56:04 2007] [notice] suEXEC mechanism enabled (wrapper: /opt/lampp/bin/suexec)
[Wed Sep 12 11:56:04 2007] [warn] RSA server certificate is a CA certificate (BasicConstraints: CA == TRUE !?)
[Wed Sep 12 11:56:04 2007] [warn] RSA server certificate CommonName (CN) `localhost' does NOT match server name!?
[Wed Sep 12 11:56:05 2007] [notice] Digest: generating secret for digest authentication ...
[Wed Sep 12 11:56:05 2007] [notice] Digest: done
[Wed Sep 12 11:56:06 2007] [warn] RSA server certificate is a CA certificate (BasicConstraints: CA == TRUE !?)
[Wed Sep 12 11:56:06 2007] [warn] RSA server certificate CommonName (CN) `localhost' does NOT match server name!?
[Wed Sep 12 11:56:06 2007] [notice] Apache/2.2.4 (Unix) DAV/2 mod_ssl/2.2.4 OpenSSL/0.9.8e PHP/5.2.3 mod_apreq2-20051231/2.5.7 mod_perl/2.0.2 Perl/v5.8.7 configured -- resuming normal operations



Message from system, nothing from browser.

Login failed. Please check your user name/password and try again.

Thanks for your time.

Seba

  • Newbie
  • *
  • Posts: 12
After finished install,login failed.
« Reply #11 on: September 12, 2007, 12:22:34 pm »
I've forgot de os, I'm using ubuntu 7.04.

calemadmin

  • Administrator
  • Calem Hero
  • *****
  • Posts: 300
    • http://www.calemeam.com
After finished install,login failed.
« Reply #12 on: September 12, 2007, 12:27:39 pm »
It seems the app is running. open CalemEAM/etc/log4php.properties, what's the property's value: log4php.appender.F1.File?
The log file might be in an odd place.
Calem Community Forum Admin

Seba

  • Newbie
  • *
  • Posts: 12
After finished install,login failed.
« Reply #13 on: September 12, 2007, 01:23:58 pm »
_CALEM_LOG_PATH_

calemadmin

  • Administrator
  • Calem Hero
  • *****
  • Posts: 300
    • http://www.calemeam.com
After finished install,login failed.
« Reply #14 on: September 12, 2007, 01:44:49 pm »
Go to CalemEAM/bin, run setup.bat (or setup.sh),
which should replace the constant with a file name. Make sure this is the case after running the setup.sh (in linux case). Then, do another login, the log file should be generated.
Calem Community Forum Admin