Author Topic: Community Version installation Problem  (Read 5214 times)

pzc

  • Newbie
  • *
  • Posts: 2
Community Version installation Problem
« on: July 03, 2016, 01:24:05 am »
I am trying to install CalemEAM R2.1 C to track equipment in a new maternity hospital in Africa.

I am using Ubunto 16.04, Apache2, PHP 7.0 and MYSQL 5.0.12.

Up to the point of the final step in the installation process things seem to have quite well - for future documentation chgrp seems no longer to be not part of Ubuntu.

After choosing express installation I receive the error message that the server is unable to handle the request..the Apache error log shows an error condition that seems very similar to an earlier post relating to WAMP versions.

[PHP Notice:  Only variable references should be returned by reference in /var/www/html/CalemEAM/server/include/log4php/LoggerAppender.php on line 73
[PHP Notice:  Only variable references should be returned by reference in /var/www/html/CalemEAM/server/include/log4php/LoggerPropertyConfigurator.php on line 565
[PHP Notice:  Undefined index: validation in /var/www/html/CalemEAM/installation/form/controller/CalemInstallFront.php on line 61

etc etc

Can anyone suggest a way forward?








calemadmin

  • Administrator
  • Calem Hero
  • *****
  • Posts: 300
    • http://www.calemeam.com
Re: Community Version installation Problem
« Reply #1 on: July 07, 2016, 05:08:42 am »
Error reporting in php.ini might have a default value to show all minor notices, which interferes with the web page rendering.
error_reporting = E_ALL

If you are using PHP 5.3.x or later, the error reporting needs to be:
error_reporting = E_ALL & ~E_NOTICE & ~E_STRICT & ~E_DEPRECATED
Calem Community Forum Admin

pzc

  • Newbie
  • *
  • Posts: 2
Re: Community Version installation Problem
« Reply #2 on: July 14, 2016, 01:28:07 am »
I am afraid that I became frustrated in trying to fix and have now installed under Windows 10 using the XAMPP stack 1.8.2 including the older PHP 5.4.16 and now installation is fine.